Is something wrong with the online store?

For technical discussion, announcements, ideas, and issue reporting for Brendan's main website and/or the forum itself.
EdvinW
Posts: 114
Joined: Tue Jun 05, 2018 6:02 pm
Location: Sweden

Is something wrong with the online store?

Post by EdvinW » Mon Jun 17, 2019 10:14 pm

I've been trying to order some gasket-valves, but I can't seem to check out from the online store. I enter some products into my cart, and open the window to view it. There is a button for checking out with PayPal, but when I click it there is a pop-up window informing me I must enter a zip code. When I enter a zip code and update the cart, however, the PayPal button disappears! I've tried to enter various different zip codes for a few different countries, but this happens every time. I find no other way of completing my order.

I normally run various ad blocking plug-ins, but as I've disabled them all without improvement I doubt this is the problem. Has anyone else experienced the same problem?

I'm eager to try these new valves, so I hope the problem can be solved!
Edvin Wedin

User avatar
RunBanjoRun
Posts: 25
Joined: Fri Mar 24, 2017 11:39 am
Location: Canterbury

Re: Is something wrong with the online store?

Post by RunBanjoRun » Tue Jun 18, 2019 9:09 am

Hello Edvin

Someone else reported the same issue a few days ago, despite other orders coming in. I think it might be an issue with browser autofill with this cart system.

However, from today we are now using a new version of the shopping cart. Could you please try again?

David
Hey I'm the forum admin - message me if you have any ideas or requests :idea: :idea: :idea:

David

Lizzy
Posts: 134
Joined: Sun May 07, 2017 1:42 pm
Location: Sweden

Re: Is something wrong with the online store?

Post by Lizzy » Tue Jun 18, 2019 10:42 am

I did have some problems a while ago but i discoverd that my problem was that i was ordering from my phone. Everything was solved when i switched to my computer.

User avatar
RunBanjoRun
Posts: 25
Joined: Fri Mar 24, 2017 11:39 am
Location: Canterbury

Re: Is something wrong with the online store?

Post by RunBanjoRun » Tue Jun 18, 2019 12:18 pm

Lizzy wrote:
Tue Jun 18, 2019 10:42 am
I did have some problems a while ago but i discoverd that my problem was that i was ordering from my phone. Everything was solved when i switched to my computer.
Hello Lizzy. Ordering should work from all devices so please do report any problems you encounter.

As well as the new shopping cart interface we are also making some changes to the top menu system to make things easier to find and also to make the interface more user friendly on mobile displays. These changes will be made later today. All feedback welcome!
Hey I'm the forum admin - message me if you have any ideas or requests :idea: :idea: :idea:

David

User avatar
triona
Posts: 210
Joined: Thu Mar 30, 2017 3:24 pm
Location: Aue / Germany

Re: Is something wrong with the online store?

Post by triona » Tue Jun 18, 2019 1:23 pm

RunBanjoRun wrote:
Tue Jun 18, 2019 12:18 pm
As well as the new shopping cart interface we are also making some changes to the top menu system to make things easier to find and also to make the interface more user friendly on mobile displays.

I really will appreciate that. Up till now the structure of the site seemed quite obscure to me and not very user friendly - at least to my personal opinion. As a matter of fact it always took a long time to find anything I looked for - if I found it at all.

And I hope that more user friendly design for mobile phones does not come along with less compatibility to usual old machines, like this is to observe quite often. (At least, I use MSWin7 and googl Chrome in a fairly current version - maybe it is self updating automatically - and current Kaspersky internet security with medium sharp set up.) And I do not intend to change this that soon. Those who try to force me to use any software which will not run properly and user friendly any more on my system will eventually loose a client. ;) And smartphuck, i-pot, apes, facetwit etc certainly will not come into my house and even less into my handbag. :twisted: (Sorry, the :twisted: does not mean you. It is meant the IT industry.)


And since you are hunting bugs anyway: Newly I had one on the forum. (Yesterday for the second time.) When I wanted to send a post there continuously was shown the automatic message

"Forbidden
You don't have permission to access /forum/posting.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."


This happened only some times and not always (2/about 5 or 10 within the last week). Only after I had changed the content of the post after several unsuccessful tries at several different times of the day strangely the posts were accepted eventually.


dear greetings
triona
Aw, Thou beloved, do hearken to the Banshee's lonely croon!
sinn féin - ça ira !
Cad é sin do'n té sin nach mbaineann sin dó


https://www.youtube.com/channel/UC1yI3H ... 9ktgzTR2qg

User avatar
RunBanjoRun
Posts: 25
Joined: Fri Mar 24, 2017 11:39 am
Location: Canterbury

Re: Is something wrong with the online store?

Post by RunBanjoRun » Tue Jun 18, 2019 1:48 pm

Thanks Triona. I will look into that error on the forum for you.

In terms of finding things on the site, we are also looking into bringing back a search function. Feel free to let me know if you have any other ideas or requests.
Hey I'm the forum admin - message me if you have any ideas or requests :idea: :idea: :idea:

David

User avatar
triona
Posts: 210
Joined: Thu Mar 30, 2017 3:24 pm
Location: Aue / Germany

Re: Is something wrong with the online store?

Post by triona » Tue Jun 18, 2019 4:16 pm

RunBanjoRun wrote:
Tue Jun 18, 2019 1:48 pm
Thanks Triona. I will look into that error on the forum for you.

Thanks.

Maybe this will help you with the research:
The first post refused maybe had overlength.
It was that one: post_id=2170, id=2171, id=2172
After splitting up into three it was accepted.
The second very short one (post_id=2223) contained 2 smilies from the list ( :?: and :? ). After eventually deleting the smilies it was accepted. (But now the system seems to accept them.)


RunBanjoRun wrote:
Tue Jun 18, 2019 1:48 pm
In terms of finding things on the site, we are also looking into bringing back a search function.
This might help for the most. The lack of an effective search function - or maybe the malfunction or unvisibility of an existing - seems in fact to be one of the greatest fails of the site.

RunBanjoRun wrote:
Tue Jun 18, 2019 1:48 pm
Feel free to let me know if you have any other ideas or requests.
That is difficult to say. I suppose that the chaotic structure of the whole site is due to the most probable fact, that it is a site which has grown slowly but as a tecnical proliferation over many years, maybe hosted and maintained by a number of different people in follow, maybe among them even some ID amateurs. These usually are not the best circumstances for well running websites.

But I am nothing less than an ID specialist, and therefore not the best advisor. The website of our own business is no good example either. It is not much better than Brendan's. :roll: And the man who has done it is not available any more. And his successor first had to buy new software to continue it.


Maybe one thing: The drop down menues on top of the site (is it called navigation?) react very clumsy and reluctant to any mouse access. They do not fit into the screen's layout (even on a large broadscreen laptop) when the font is large enough to read without eyeglasses, and they tend to disappear always before it is possible to click a choice.

And the running picture bar is more disturbing than helpful. Maybe a good index is more helpful than such a kind of "suggestive leading" of the visitor inspired by newaday's marketing monsters like Emma Soon or Eagh Bhaigh. I guess this will not help Brendan to reach the sales of these. :mrgreen:


dear greetings
triona
Aw, Thou beloved, do hearken to the Banshee's lonely croon!
sinn féin - ça ira !
Cad é sin do'n té sin nach mbaineann sin dó


https://www.youtube.com/channel/UC1yI3H ... 9ktgzTR2qg

User avatar
RunBanjoRun
Posts: 25
Joined: Fri Mar 24, 2017 11:39 am
Location: Canterbury

Re: Is something wrong with the online store?

Post by RunBanjoRun » Wed Jun 19, 2019 5:28 pm

Thank you for all that very useful feedback, Triona.

For the error messages you and others are sometimes getting when posting on here, we have today made some permissions changes which we expect to have fixed the issue. If not, please do let me know.
Hey I'm the forum admin - message me if you have any ideas or requests :idea: :idea: :idea:

David

User avatar
triona
Posts: 210
Joined: Thu Mar 30, 2017 3:24 pm
Location: Aue / Germany

Re: Is something wrong with the online store?

Post by triona » Wed Jun 19, 2019 7:16 pm

thanx. we will see.
Concerning the web shop, we will see what the next order will bring.
The most outstanding problems I always had with that were caused by f§$%ing paypal.

greez tri
Aw, Thou beloved, do hearken to the Banshee's lonely croon!
sinn féin - ça ira !
Cad é sin do'n té sin nach mbaineann sin dó


https://www.youtube.com/channel/UC1yI3H ... 9ktgzTR2qg

User avatar
triona
Posts: 210
Joined: Thu Mar 30, 2017 3:24 pm
Location: Aue / Germany

Re: Is something wrong with the online store?

Post by triona » Tue Jul 09, 2019 4:31 pm

Hi David,

once more:

Forbidden
You don't have permission to access /forum/posting.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


After several effortless tries there always came this:

Die Website ist nicht erreichbar
Die Antwort von www.brendan-power.com hat zu lange gedauert.
• Auf Google nach brendan power forum index suchen
ERR_CONNECTION_TIMED_OUT

in English: The web site is not accessable.
Response of www.brendan-power.com did last too long.


And it was not accessable any more for half a day after this (for several times).

1. Tried to shorten the post. No effect.
Is there any limitation to the lenghth of a post at all? And in case of yes, how many characters?

2. Deleted all smilies.
But once (with a small part of the text) it worked with all the smilies.
From the next try it did not work any more at all. This time most probably not the cause of failure.

3. Then I did it like this:
viewtopic.php?f=7&p=2292#p2292
(Link to a PDF on an external server.)
That causes more work than usual. And no quotation of the post possible in the normal way.

4. One more possible cause could be:
Importation of text from a MSword-Document.
Usually the bug came when doing so.
Possibly the forum's server or software is not compatible to this.

Why I do so? If the edition of a post takes too long time, there seems to be some time out and I am logged out automatically while editing the post. This can cause the loss of the whole text. Therefore editing and saving on own resources and importation or reimportation.
My text editor is Microsoft Word 2007, as delivered with MS Windows7
No problems with this with any other forum in the world up till now, and sometimes even not with this one.

Maybe you can find the bug and fix it.


dear greetings
triona
Aw, Thou beloved, do hearken to the Banshee's lonely croon!
sinn féin - ça ira !
Cad é sin do'n té sin nach mbaineann sin dó


https://www.youtube.com/channel/UC1yI3H ... 9ktgzTR2qg

Post Reply